[Webkit-unassigned] [Bug 132814] [Stable] [GTK] GdiObject.h missing in WebKitGTK 2.4.1 tarball

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 21 08:49:44 PDT 2014


--- Comment #7 from Milan Crha <mcrha at redhat.com>  2014-05-21 08:50:07 PST ---
(In reply to comment #6)
> (In reply to comment #4)
> > there had been some issues with GdiObject itself, mingw/msys has a
> > clash with deleteObject, thus I renamed it to deleteObjectGDI
> Doesn't the WTF namespace prevent this problem from happening?

I did not investigate it into deep, thus I do not know from where the clash comes, but if it's a define, then the namespace wouldn't help.

The thing is, without rename I get a compiler error (I can regenerate it, if it helps), then I searched the Internet and one way to fix it was to rename the symbol, which I did and it helped.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list