[Webkit-unassigned] [Bug 132917] remove duplicate code in web timing

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 14 11:22:13 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=132917


Alexey Proskuryakov <ap at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #231459|review?                     |review+
               Flag|                            |




--- Comment #2 from Alexey Proskuryakov <ap at webkit.org>  2014-05-14 11:22:36 PST ---
(From update of attachment 231459)
View in context: https://bugs.webkit.org/attachment.cgi?id=231459&action=review

> Source/WebCore/platform/network/ResourceHandle.h:33
> +#include "ResourceLoadTiming.h"

Please don't include it, just forward declare.

> Source/WebCore/platform/network/ResourceHandle.h:134
> +    static void transferTimingData(NSURLConnection*, ResourceLoadTiming&);

I'd say "get", not "transfer".

> Source/WebCore/platform/network/mac/WebCoreResourceHandleAsDelegate.mm:175
> +    ResourceHandle::transferTimingData(connection, resourceResponse.resourceLoadTiming());

This is not what I was thinking of - I think that a nicer way to implement this would be to call into ResourceHandle here, which would then read the timing data, and call the client. Duplicating even the ResourceHandle::transferTimingData still leaves the potential for us to forget about it in future reimplementations.

It's OK to land as is though, the patch is an improvement.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list