[Webkit-unassigned] [Bug 132854] Remove check-webkit-style warnings in JavascriptCore/dfg

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 14 09:26:39 PDT 2014


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
 Attachment #231440|review?                     |review-
               Flag|                            |

--- Comment #2 from Darin Adler <darin at apple.com>  2014-05-14 09:27:02 PST ---
(From update of attachment 231440)
View in context: https://bugs.webkit.org/attachment.cgi?id=231440&action=review

Most of the changes look like small improvements, but some of them make things a little worse and should not be done.

> Source/JavaScriptCore/dfg/DFGCapabilities.h:50
> -inline CapabilityLevel capabilityLevel(OpcodeID opcodeID, CodeBlock* codeBlock, Instruction* pc);
> +inline CapabilityLevel capabilityLevel(OpcodeID, CodeBlock*, Instruction*);

I am not sure that removing the name “pc” makes the code more clear. I would probably leave it in.

> Source/JavaScriptCore/dfg/DFGSpeculativeJIT.h:1974
> -    void addBranch(const MacroAssembler::JumpList& jump, BasicBlock* destination);
> +    void addBranch(const MacroAssembler::JumpList&, BasicBlock*);

Removing the name “destination” makes this less clear.

> Source/JavaScriptCore/dfg/DFGSpeculativeJIT.h:2243
> +    void speculateString(Edge, GPRReg);
> +    void speculateStringIdentAndLoadStorage(Edge, GPRReg, GPRReg);
> +    void speculateStringIdent(Edge, GPRReg);

Removing the names “cell”, “string”, and “storage” here makes this less clear. Those names aren’t redundant.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list