[Webkit-unassigned] [Bug 82288] nested image tags fail on svg's

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 13 08:00:11 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=82288


Dirk Schulze <krit at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |RESOLVED
         Resolution|                            |INVALID
                 CC|                            |krit at webkit.org




--- Comment #3 from Dirk Schulze <krit at webkit.org>  2014-05-13 08:00:33 PST ---
(In reply to comment #2)
> (In reply to comment #1)
> > Thanks for the bug report, we don't support sub-resource loading in SVGImages at the moment.
> > CC'ing Reni.
> 
> Actually one level of sub SVG works.

It did but shouldn't anymore.

> 
> I believe that this is a rather interesting problem, due to the fact that users are going to have to disassemble an SVG file to know how many nests are involved.  Could this at least spit out a console error to let the user have a clue as to what is happening?  Or keep on recursing to attempt to display the image?
> 
> Thanks
> 
> so.
> 
> SVG MAIN <- DISPLAYS
>     SVG FIRST NEST  <- DISPLAYS without SVG IMAGE
>        SVG  SECOND NEST (IN  SVG FIRST NEST)  <- DOES NOT DISPLAY DISPLAYS

Yes, there could be a console message warning the user that further external resources can not be loaded. dataURL should work but don't at the moment. We have a bug for that.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list