[Webkit-unassigned] [Bug 130709] [iOS] Inspector View Indication Support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 24 23:06:40 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=130709


Simon Fraser (smfr) <simon.fraser at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #227716|review+                     |review-
               Flag|                            |




--- Comment #2 from Simon Fraser (smfr) <simon.fraser at apple.com>  2014-03-24 23:07:00 PST ---
(From update of attachment 227716)
View in context: https://bugs.webkit.org/attachment.cgi?id=227716&action=review

> Source/WebKit2/UIProcess/API/Cocoa/WKWebView.mm:1097
> +- (void)_startIndicatingView

"indicatingView" is ambiguous and not really good English. It should be read as -(UIView*)indicatingView, but I think you mean it as the view is "indicating the state of being inspected".

How about showShowingInspectionIndication/indicator? Or -(void)setIsShowingInspectionIndicator:(BOOL)?

> Source/WebKit2/UIProcess/PageClient.h:255
> +    virtual void startIndicatingView() = 0;
> +    virtual void stopIndicatingView() = 0;

Same bad naming.

> Source/WebKit2/UIProcess/ios/WKContentView.mm:64
> + at interface IndicateView : UIView

I think this class name should contain "inspector". It should have a prefix (WK or Web?), maybe with an underscore. Web/WKInspectorIndicationView?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list