[Webkit-unassigned] [Bug 130577] implement ewk web storage API in ewk_context for EFL

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 21 18:54:16 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=130577





--- Comment #4 from Jinwoo Song <jinwoo7.song at samsung.com>  2014-03-21 18:54:34 PST ---
(From update of attachment 227413)
View in context: https://bugs.webkit.org/attachment.cgi?id=227413&action=review

You should add unit tests for newly added APIs.

> Source/WebKit2/UIProcess/API/efl/ewk_context.h:362
> +typedef void (*Ewk_Web_Storage_Origins_Get_Callback)(Eina_List* origins, void *user_data);

Duplicated with Ewk_Storage_Origins_Async_Get_Cb in ewk_stroage_manager.h

> Source/WebKit2/UIProcess/API/efl/ewk_context.h:371
> +EAPI Eina_Bool ewk_context_web_storage_delete_all(Ewk_Context *context);

It would be better to move into ewk_storage_manager and change the name to *ewk_storage_manager_all_entries_delete(Ewk_Storage_Manager *manager)*.

> Source/WebKit2/UIProcess/API/efl/ewk_context.h:380
> +EAPI Eina_Bool ewk_context_web_storage_origin_delete(Ewk_Context *context, Ewk_Security_Origin *origin);

It would be better to move into ewk_storage_manager and change the name to *ewk_storage_manager_entries_for_origin_delete(Ewk_Storage_Manager *manager, Ewk_Security_Origin *origin)*.

> Source/WebKit2/UIProcess/API/efl/ewk_context.h:394
> +EAPI Eina_Bool ewk_context_web_storage_origins_get(Ewk_Context *context, Ewk_Web_Storage_Origins_Get_Callback callback, void *user_data);

Duplicated with ewk_storage_manager_origins_async_get() in ewk_stroage_manager.h

> Source/WebKit2/UIProcess/API/efl/ewk_context.h:397
> + * Requests for setting web storage path.

This API sets the local storage path but does not set the session storage path. So it is right to comment *local* not *web*.

> Source/WebKit2/UIProcess/API/efl/ewk_context.h:400
> + * @param path web storage path to set

ditto.

> Source/WebKit2/UIProcess/API/efl/ewk_context.h:404
> +EAPI Eina_Bool ewk_context_web_storage_path_set(Ewk_Context *context, const char *path);

It would better to rename to *ewk_context_local_storage_path_set(Ewk_Context *context, const char *path)*.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list