[Webkit-unassigned] [Bug 134339] Add option to specify output file location in sunspider.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 30 01:33:06 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=134339


Csaba Osztrogonác <ossy at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #233889|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |




--- Comment #2 from Csaba Osztrogonác <ossy at webkit.org>  2014-06-30 01:33:23 PST ---
(From update of attachment 233889)
View in context: https://bugs.webkit.org/attachment.cgi?id=233889&action=review

The base idea is good, but r- now due to some minor issue.

> PerformanceTests/SunSpider/sunspider:45
> +my $outputPath = "";

We don't need this extra variable, we can use this one:
my $resultsFile = "";

> PerformanceTests/SunSpider/sunspider:61
> +  --output-path     If given set the output file and its path.

I prefer --output.

> PerformanceTests/SunSpider/sunspider:75
> +           'output-path=s' => \$outputPath,

'output=s' => \$resultsFile,

> PerformanceTests/SunSpider/sunspider:131
>  my $resultsFile = "$resultDirectory/sunspider-results-$timeString.js";
> +if ($outputPath) {
> +  $resultsFile = $outputPath;
> +}

You can do it in one line:
$resultsFile = "$resultDirectory/sunspider-results-$timeString.js" unless $resultsFile;

> Tools/Scripts/run-sunspider:65
> +  --output-path     If given set the output file and its path.

Simple --output would be better name, and the comment like "Override the default output path and filename"

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list