[Webkit-unassigned] [Bug 134300] New: [GTK] Expose getter and setter for attributes named type

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 25 09:06:05 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=134300

           Summary: [GTK] Expose getter and setter for attributes named
                    type
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Keywords: Gtk
          Severity: Normal
          Priority: P2
         Component: Bindings
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: cgarcia at igalia.com
            Blocks: 133724


We skip those because the getter conflicts with the get_type() function of all GObjects. We can use a different name for them. As a general rule we can use the last word of the class name, something like:

webkit_dom_blob_get_type() -> webkit_dom_blob_get_blob_type()
webkit_dom_event_get_type() -> webkit_dom_event_get_event_type()

That's consistent with other existing DOM methods like webkit_dom_xpath_result_get_result_type() or webkit_dom_css_value_get_css_value_type().

We would still need to add some exceptions, but they are not that much in the end.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list