[Webkit-unassigned] [Bug 135195] Refactor EventHandler to call ScrollAnimator::handleWheelEvent for overflow scrolling

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 30 15:31:37 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=135195


Beth Dakin <bdakin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #235721|review?                     |review+
               Flag|                            |




--- Comment #31 from Beth Dakin <bdakin at apple.com>  2014-07-30 15:31:48 PST ---
(From update of attachment 235721)
View in context: https://bugs.webkit.org/attachment.cgi?id=235721&action=review

Looks good!

> Source/WebCore/page/EventHandler.cpp:292
> +    return scrollableArea->scroll(delta < 0 ? negativeDirection : positiveDirection, wheelGranularityToScrollGranularity(wheelEvent->deltaMode()), delta > 0 ? delta : -delta);

So much more readable!!

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list