[Webkit-unassigned] [Bug 135195] Refactor EventHandler to call ScrollAnimator::handleWheelEvent for overflow scrolling
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Jul 28 16:59:17 PDT 2014
https://bugs.webkit.org/show_bug.cgi?id=135195
--- Comment #23 from Tim Horton <thorton at apple.com> 2014-07-28 16:59:29 PST ---
(From update of attachment 235613)
View in context: https://bugs.webkit.org/attachment.cgi?id=235613&action=review
> Source/WebCore/page/EventHandler.cpp:311
> + *stopElement = currentEnclosingBox->element();
that's a lot of nesting :| can we make this flatter?
> Source/WebCore/page/EventHandler.cpp:-2640
> - dominantDirection = m_recentWheelEventDeltaTracker->dominantScrollGestureDirection();
where did all this code go?
> Source/WebCore/rendering/RenderNamedFlowThread.cpp:378
> +RenderBlock* RenderNamedFlowThread::fragmentFromCurrentlyScrollingBlockAsRenderBlock(RenderBlock* renderBlock, const IntPoint& absolutePoint, const RenderBox& flowedBox)
this name seems a bit weird since what the function does doesn't seem to have anything to do with scrolling?
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list