[Webkit-unassigned] [Bug 134674] [EFL][WK2] Add a "focus, control, handover" signal.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 16 19:04:29 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=134674





--- Comment #14 from Gyuyoung Kim <gyuyoung.kim at webkit.org>  2014-07-16 19:04:39 PST ---
(From update of attachment 234990)
View in context: https://bugs.webkit.org/attachment.cgi?id=234990&action=review

>>>>> Source/WebKit2/UIProcess/API/efl/ewk_view.h:42
>>>>> + * - "focus,control,handover", Ewk_Focus_Direction*: reports that user can take the focus from the ewk_view because
>>>> 
>>>> This signal is to notify if focus direction is changed. EWK_FOCUS_DIRECTION_FORWARD or EWK_FOCUS_DIRECTION_BACKWARD. This signal name doesn't contain meaning for user. "focus,direction,changed" looks better. Besides your description regarding "handover focus control bla bla..." is redundant. We only need to explain what does this signal report.
>>> 
>>> IMHO, This signal is to notify that there is no focusable element when we press the tab or tab + shift keys regardless of focus direction.
>>> Purpose of this signal is to notify that application can handover focus control.
>>> Therefore I think this signal name is not bad but you still prefer to "focus,direction,changed", I'll fix it.
>> 
>> Doesn't Application get focus direction eventually ? Anyway, I think we should use a signal name from the signal occurrence of view.
>> 
>> Look at existing signals
>> 
>> "title,changed",
>> "url,changed",
>> "webprocess,crashed",
>> 
>> If this signal is for notifying there isn't any focusable element, it looks "focus,notfound" can be one of candidates.
> 
> In my understanding,
> this signal is fired when user requests to move the focus as specified direction but webview can't move the focus because webvuew already reached the last focusable element of that direction.
> 
> So, ewk_view does not change any state of itself. It just propagate to the container or application to know that it's your turn to treat user's navigation action.
> 
> As user scenarios,
> applications may decide 
> - to move the focus to next widget of ewk_view (normal behavior which I think)
> - or to move the first focusable element of webview (recursive focus)
> - or to do nothing
> 
> Anyway, although I agree with you that this signal name(focus,control,handover) is not usual, I don't have good idea for the better name.

Right, ryuan. it would be nicer if we add your suggestion to signal description.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list