[Webkit-unassigned] [Bug 134794] New: Split DEFINE_STATIC_LOCAL into two: one without any argument and the other with argument

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 9 20:48:56 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=134794

           Summary: Split DEFINE_STATIC_LOCAL into two: one without any
                    argument and the other with argument
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Web Template Framework
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: vivekg at webkit.org


Splitting DEFINE_STATIC_LOCAL into two for better readability of the code. In this, one is without 
any arguments whereas the other macro takes argument as macro param. This CL makes these calls 
more explicit. 

The macros DEFINE_STATIC_LOCAL and DEFINE_STATIC_LOCAL_WITH_ARG are defined in Source/wtf/StdLibExtras.h 

The following commands are executed in order to change this: 
git ls-files | xargs sed -i 's/DEFINE_STATIC_LOCAL\((.*\)\(, ()\)/DEFINE_STATIC_LOCAL_WITHOUT_ARG\1/g' 
git ls-files | xargs sed -i 's/DEFINE_STATIC_LOCAL(/DEFINE_STATIC_LOCAL_WITH_ARG(/g' 
git ls-files | xargs sed -i 's/DEFINE_STATIC_LOCAL_WITHOUT_ARG(/DEFINE_STATIC_LOCAL(/g'

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list