[Webkit-unassigned] [Bug 127760] Change a logic for touching slider in "RangeInput::handleTouchEvent"
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Jan 28 11:13:31 PST 2014
https://bugs.webkit.org/show_bug.cgi?id=127760
--- Comment #2 from Joseph Pecoraro <joepeck at webkit.org> 2014-01-28 11:10:55 PST ---
(From update of attachment 222407)
View in context: https://bugs.webkit.org/attachment.cgi?id=222407&action=review
> Source/WebCore/html/RangeInputType.cpp:177
> - TouchList* touches = event->targetTouches();
> + TouchList* touches = event->touches();
> if (touches->length() == 1) {
> typedSliderThumbElement().setPositionFromPoint(touches->item(0)->absoluteLocation());
> event->setDefaultHandled();
This is in non-iOS code, so I probably won't be the final reviewer, but why would you want to change from targetTouches to touches here?
Could you try to better describe the scenario you're fixing? I am having trouble understanding your comment in the ChangeLog.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list