[Webkit-unassigned] [Bug 127543] Move JavaScriptCallFrame and ScriptDebugServer into JavaScriptCore for inspector
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri Jan 24 17:43:01 PST 2014
https://bugs.webkit.org/show_bug.cgi?id=127543
Joseph Pecoraro <joepeck at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
CC| |joepeck at webkit.org
--- Comment #9 from Joseph Pecoraro <joepeck at webkit.org> 2014-01-24 17:40:29 PST ---
(In reply to comment #8)
> (From update of attachment 222171 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=222171&action=review
>
> > Source/JavaScriptCore/inspector/JSJavaScriptCallFramePrototype.cpp:66
> > +#define JSC_NATIVE_NON_INDEX_ACCESSOR(jsName, cppName, attributes) \
>
> Any reason this can't be an inline function?
This, like the other JSC_NATIVE* macros, assumes you have "exec, globalObject, and vm" variables in scope with those names. So turning this into inline function would double the number of arguments to JSC_NATIVE_NON_INDEX_ACCESSOR making it a bit harder to read. However, it would get rid of the need for the anonymous scope in the macro. I like the easier to read call site matching JSC_NATIVE_FUNCTION.
Would an inline function be preferred?
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list