[Webkit-unassigned] [Bug 126696] DocumentOrderedMap should use iterator

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 9 08:50:53 PST 2014


https://bugs.webkit.org/show_bug.cgi?id=126696


Andreas Kling <akling at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #220738|review?                     |review+
               Flag|                            |




--- Comment #3 from Andreas Kling <akling at apple.com>  2014-01-09 08:48:35 PST ---
(From update of attachment 220738)
View in context: https://bugs.webkit.org/attachment.cgi?id=220738&action=review

> Source/WebCore/dom/DocumentOrderedMap.cpp:213
> +        auto elementDescandants = descendantsOfType<Element>(*scope.rootNode());

Typo, descandants.

> Source/WebCore/dom/DocumentOrderedMap.cpp:214
> +        auto it = entry.element ? elementDescandants.find(*entry.element) : elementDescandants.begin();

We need a better name for find(). beginAt()?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list