[Webkit-unassigned] [Bug 126148] Support <box> values computed style for 'clip-path' property
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Jan 1 22:46:11 PST 2014
https://bugs.webkit.org/show_bug.cgi?id=126148
Simon Fraser (smfr) <simon.fraser at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #220028|review?, commit-queue? |review+, commit-queue-
Flag| |
--- Comment #14 from Simon Fraser (smfr) <simon.fraser at apple.com> 2014-01-01 22:44:01 PST ---
(From update of attachment 220028)
View in context: https://bugs.webkit.org/attachment.cgi?id=220028&action=review
> Source/WebCore/css/CSSComputedStyleDeclaration.cpp:2869
> + ReferenceClipPathOperation& referenceOperation = *toReferenceClipPathOperation(operation);
I think it would be slightly better to say
ReferenceClipPathOperation& referenceOperation = toReferenceClipPathOperation(*operation);
> Source/WebCore/css/CSSComputedStyleDeclaration.cpp:2875
> + ShapeClipPathOperation& shapeOperation = *toShapeClipPathOperation(operation);
Ditto
> Source/WebCore/css/CSSComputedStyleDeclaration.cpp:2881
> + BoxClipPathOperation& boxOperation = *toBoxClipPathOperation(operation);
Ditto
> Source/WebCore/rendering/ClipPathOperation.h:148
> + const Path& path(const FloatRect&)
This is confusing. Is it going to return path that just contains the given rect? Should it be called pathForRect()? Why does this change m_path?
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list