[Webkit-unassigned] [Bug 127057] New: [CSS Grid Layout] minmax() should be a CSSFunction instead of a CSSValueList

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 15 10:43:37 PST 2014


https://bugs.webkit.org/show_bug.cgi?id=127057

           Summary: [CSS Grid Layout] minmax() should be a CSSFunction
                    instead of a CSSValueList
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: CSS
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: svillar at igalia.com


We're internally treating the minmax() function as a list of CSSValue instead of a CSSFunction. The problem with that is that a declaration like

    -webkit-grid-definition-columns: minmax(10px, 50px)

will be transformed, when asking for "element.style.webkitGridDefinitionColumns" in 

    "10px 50px"

i.e. a string with a list of values instead of

    "minmax(10px, 50px)"

which is the correct value in this case.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list