[Webkit-unassigned] [Bug 121694] Assertion failure in Range::nodeWillBeRemoved

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 15 09:24:10 PST 2014


https://bugs.webkit.org/show_bug.cgi?id=121694





--- Comment #5 from Ryosuke Niwa <rniwa at webkit.org>  2014-01-15 09:21:47 PST ---
(From update of attachment 221248)
View in context: https://bugs.webkit.org/attachment.cgi?id=221248&action=review

> Source/WebCore/dom/ContainerNode.cpp:490
> +    if (child.parentNode())

We should check that child.parentNode() == this as done in ContainerNode::removeChild.

> LayoutTests/fast/dom/Range/remove-twice-crash.html:8
> +function $(id) { return document.getElementById(id); }

Please don't add this function.  It makes the code less readable.

> LayoutTests/fast/dom/Range/remove-twice-crash.html:20
> +range.selectNode($('sample'));

Call getElementById directly here and store it in a local variable.
Also, sample is a terrible name for this element.

> LayoutTests/fast/dom/Range/remove-twice-crash.html:23
> +    $('sample').parentNode.removeChild($('sample'));

Ditto.

> LayoutTests/fast/dom/Range/remove-twice-crash.html:28
> +$('container').outerHTML = 'PASS; NOT CRASHED';

We should add a description as to what kind of behavior this test is testing.
Otherwise the expected result doesn't tell us anything about this test.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list