[Webkit-unassigned] [Bug 126208] Define WebProcess::usesNetworkProcess unconditionally

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 3 00:03:30 PST 2014


https://bugs.webkit.org/show_bug.cgi?id=126208





--- Comment #8 from Carlos Garcia Campos <cgarcia at igalia.com>  2014-01-03 00:01:19 PST ---
(In reply to comment #7)
> > This only allows to avoid the ifdefs when the only thing used is usesNetworkProcess, the cases you mentioned use other API only defined inside ENABLE(NETWORK_PROCESS) blocks, like  NetworkProcessProxy in DownloadProxy::cancel() or NetworkConnectionToWebProcessMessages in platform strategies.
> 
> Yes, I was asking whether these can be easily moved out of ifdefs too. It's really inconsistent to keep most of the ifdefs around, and I'm not sure if this patch is much of an improvement right now.

I don't think it's possible. Well, the patch mainly tries to avoid these kind of things:

#if ENABLE(NETWORK_PROCESS)
    if (!m_usesNetworkProcess) {
#endif
#if ENABLE(CUSTOM_PROTOCOLS)
        for (const auto& scheme : globalURLSchemesWithCustomProtocolHandlers())
            parameters.urlSchemesRegisteredForCustomProtocols.append(scheme);
#endif
#if ENABLE(NETWORK_PROCESS)
    }
#endif

I find a lot easier to read this:

if (!usesNetworkProcess) {
#if ENABLE(CUSTOM_PROTOCOLS)
        for (const auto& scheme : globalURLSchemesWithCustomProtocolHandlers())
            parameters.urlSchemesRegisteredForCustomProtocols.append(scheme);
#endif
}

If you think this doesn't improve anything, feel free to close the bug and I'll focus on soup specific changes only.

> > Do we really need disk cache, or cookies for those loads?
> 
> We need cookies and http credentials for appcache for sure, otherwise it would be impossible to install an offline app from a protected site.

Ok, thanks for clarifying it. I'll make sure this still works.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list