[Webkit-unassigned] [Bug 129263] WebKitFindOptions shouldn't expose WEBKIT_FIND_OPTIONS_SHOW_{OVERLAY, FIND_INDICATOR, HIGHLIGHT}

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 26 03:41:45 PST 2014


https://bugs.webkit.org/show_bug.cgi?id=129263


Sergio Villar Senin <svillar at igalia.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #225163|review?                     |review+
               Flag|                            |




--- Comment #6 from Sergio Villar Senin <svillar at igalia.com>  2014-02-26 03:38:52 PST ---
(From update of attachment 225163)
View in context: https://bugs.webkit.org/attachment.cgi?id=225163&action=review

r=me provided you fix the issues I mention.

> Source/WebKit2/UIProcess/API/gtk/WebKitFindController.cpp:86
> +namespace FindOptions {

Let's use a different function name instead of adding another namespace, see bellow.

> Source/WebKit2/UIProcess/API/gtk/WebKitFindController.cpp:88
> +static inline WebKit::FindOptions toFindOptions(uint32_t type)

I'd suggest toWebFindOptions for example.

BTW, I spot this in the previous review but forgot to add a comment. Let's change the name of the argument, "type" does not mean anything, we need a more meaningful name like findOptions for example.

> Source/WebKit2/UIProcess/API/gtk/WebKitFindController.cpp:97
> +static inline WebKitFindOptions toWebKitFindOptions(uint32_t type)

Same thing about the name of the argument.

> Source/WebKit2/UIProcess/API/gtk/WebKitFindController.cpp:106
> +} // namespace WebKitFindController

We can remove this then.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list