[Webkit-unassigned] [Bug 123889] [ATK] "Indeterminate" state and state changes in tri-state checkboxes should be exposed to ATs

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 14 09:05:27 PST 2014


https://bugs.webkit.org/show_bug.cgi?id=123889





--- Comment #23 from chris fleizach <cfleizach at apple.com>  2014-02-14 09:02:40 PST ---
(From update of attachment 224190)
View in context: https://bugs.webkit.org/attachment.cgi?id=224190&action=review

> Source/WebCore/accessibility/atk/AXObjectCacheAtk.cpp:186
> +    AccessibilityObject* currentObject = coreObject;

probably don't need to make a new currentObject here. you could rename the incoming parameter to just "object" and use that

> Source/WebCore/accessibility/atk/AXObjectCacheAtk.cpp:190
> +    const AccessibilityObject::AccessibilityChildrenVector& children = currentObject->children();

const auto& children

> Source/WebCore/accessibility/atk/AXObjectCacheAtk.cpp:212
> +    AtkObject* atkObject = accessibilityTriStateObject ? accessibilityTriStateObject->wrapper() : nullptr;

i don't think you need to check if accessibilityTriStateObject == nil here because you already did that on line 205

> Source/WebCore/accessibility/atk/AXObjectCacheAtk.cpp:213
> +    if (atkObject) {

you can probably write this as
if (AtkObject* atkObject = axTriState->wrapper()) {

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list