[Webkit-unassigned] [Bug 128626] Lowering of CheckArray in FTL not supported for all types.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 11 16:02:32 PST 2014


https://bugs.webkit.org/show_bug.cgi?id=128626


Filip Pizlo <fpizlo at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #223905|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |




--- Comment #2 from Filip Pizlo <fpizlo at apple.com>  2014-02-11 15:59:49 PST ---
(From update of attachment 223905)
View in context: https://bugs.webkit.org/attachment.cgi?id=223905&action=review

> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:-1756
> -        LValue cell = lowCell(edge);

Why remove this here?

> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:1776
> +            LValue cell = lowCell(edge);            

And move it here?

> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:1792
> +        LValue cell = lowCell(m_node->child1());

... and then have to do it again here?  Seems like it was happiest at the top.

> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:1794
> +        LValue obj = m_out.loadPtr(m_out.address(cell , m_heaps.JSCell_structure)); 

I wouldn't call this "obj".  I would call it "structure".

> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:1798
> +                , m_out.constIntPtr(expectedClassInfo)));

Weird indentation and comma placement.  Put the comma at the end of the previous line.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list