[Webkit-unassigned] [Bug 136449] [GTK] UserMedia Permission Request API

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Dec 5 12:37:47 PST 2014


https://bugs.webkit.org/show_bug.cgi?id=136449

--- Comment #22 from Benjamin Poulain <benjamin at webkit.org> ---
Comment on attachment 241934
  --> https://bugs.webkit.org/attachment.cgi?id=241934
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=241934&action=review

Approved for WebKit2.

Please poke me on IRC when you need me to rubber-stamp something. I easily miss emails.

> Source/WebCore/platform/mediastream/gstreamer/MediaStreamCenterGStreamer.cpp:65
> +    // FIXME: Actually do constraints validation.

IMHO, you should extend this FIXME to fully explain what is missing.

>> Source/WebKit2/UIProcess/UserMediaPermissionRequestProxy.h:42
>> +    bool video() const { return m_video; }
> 
> What do you think about this API change, Benjamin?

That simplification make sense for the permission request but the name is a bit too generic.

Maybe audioConstraint()? needsAudio()? requestAudio()? requiresAudio()?

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20141205/7e0d1129/attachment-0002.html>


More information about the webkit-unassigned mailing list