[Webkit-unassigned] [Bug 58608] Groove/inset/outset borders show solid if the color is black

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 1 11:06:21 PST 2014


https://bugs.webkit.org/show_bug.cgi?id=58608

Simon Fraser (smfr) <simon.fraser at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #242296|review?, commit-queue?      |review+, commit-queue-
              Flags|                            |

--- Comment #52 from Simon Fraser (smfr) <simon.fraser at apple.com> ---
Comment on attachment 242296
  --> https://bugs.webkit.org/attachment.cgi?id=242296
Rewrote function, added rebaseline in TestExpectations

View in context: https://bugs.webkit.org/attachment.cgi?id=242296&action=review

Does this patch fix the table rendering issues that the earlier patch broke?

> LayoutTests/TestExpectations:143
> +webkit.org/b/58608 fast/borders/mixed-border-style2.html [ Rebaseline ]

Why did you add this here? It's just adding technical debt that someone has to clean up later.

> LayoutTests/fast/borders/mixed-border-style2.html:7
> +      -moz-box-sizing: border-box;

You can remove this.

> Source/WebCore/rendering/RenderObject.cpp:2451
> +    const RGBA32 baseDarkColor = 0xFF202020;
> +    const RGBA32 baseLightColor = 0xFFEBEBEB;

Where did these magic numbers come from?

> Source/WebCore/rendering/RenderObject.cpp:2455
> +    Operation operation = (side == BSTop || side == BSLeft) == (style == INSET) ?
> +        Darken : Lighten;

This line doesn't need to wrap.

> Source/WebCore/rendering/RenderObject.cpp:2467
> +    if (operation == Darken) {
> +        if (differenceSquared(color, Color::black) >
> +            differenceSquared(baseDarkColor, Color::black)) {
> +            color = color.dark();
> +        }
> +    } else {
> +        if (differenceSquared(color, Color::white) >
> +            differenceSquared(baseLightColor, Color::white)) {
> +            color = color.light();
> +        }
> +    }

Would be nice to add a comment justifying this behavior.

-- 
You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-unassigned/attachments/20141201/f1c641e3/attachment-0002.html>


More information about the webkit-unassigned mailing list