[Webkit-unassigned] [Bug 134301] Implement parsing for CSS scroll snap points

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 6 13:38:24 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=134301


Simon Fraser (smfr) <simon.fraser at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #235954|review?, commit-queue?      |review+, commit-queue-
               Flag|                            |




--- Comment #54 from Simon Fraser (smfr) <simon.fraser at apple.com>  2014-08-06 13:38:27 PST ---
(From update of attachment 235954)
View in context: https://bugs.webkit.org/attachment.cgi?id=235954&action=review

> Source/WebCore/css/StyleResolver.cpp:2869
> +        } else {

You could return before this line to make the logic easier to follow.

> Source/WebCore/css/StyleResolver.cpp:2877
> +            for (CSSValueListIterator i(value); i.hasMore(); i.advance()) {

i -> it

> Source/WebCore/rendering/style/RenderStyle.h:1627
> +    void setScrollSnapType(ScrollSnapType t) { SET_VAR(rareNonInheritedData, m_scrollSnapType, t); }
> +    void setScrollSnapOffsetsX(Vector<Length>& t) { SET_VAR(rareNonInheritedData.access()->m_scrollSnapPoints, offsetsX, t); }
> +    void setScrollSnapOffsetsY(Vector<Length>& t) { SET_VAR(rareNonInheritedData.access()->m_scrollSnapPoints, offsetsY, t); }
> +    void setScrollSnapRepeatOffsetX(Length t) { SET_VAR(rareNonInheritedData.access()->m_scrollSnapPoints, repeatOffsetX, t); }
> +    void setScrollSnapRepeatOffsetY(Length t) { SET_VAR(rareNonInheritedData.access()->m_scrollSnapPoints, repeatOffsetY, t); }
> +    void setScrollSnapHasRepeatX(bool t) { SET_VAR(rareNonInheritedData.access()->m_scrollSnapPoints, hasRepeatX, t); }
> +    void setScrollSnapHasRepeatY(bool t) { SET_VAR(rareNonInheritedData.access()->m_scrollSnapPoints, hasRepeatY, t); }
> +    void setScrollSnapDestinationX(Length t) { SET_VAR(rareNonInheritedData.access()->m_scrollSnapPoints, destinationX, t); }
> +    void setScrollSnapDestinationY(Length t) { SET_VAR(rareNonInheritedData.access()->m_scrollSnapPoints, destinationY, t); }
> +    void setScrollSnapCoordinates(Vector<SnapCoordinate>& t) { SET_VAR(rareNonInheritedData.access()->m_scrollSnapPoints, coordinates, t); }
> +    void setScrollSnapUsesElementsX(bool t) { SET_VAR(rareNonInheritedData.access()->m_scrollSnapPoints, usesElementsX, t); }
> +    void setScrollSnapUsesElementsY(bool t) { SET_VAR(rareNonInheritedData.access()->m_scrollSnapPoints, usesElementsY, t); }

Please use readable parameters names, rather than 't'.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list