[Webkit-unassigned] [Bug 131260] [EFL][WK2] Fix unused parameter compile warning

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Apr 5 03:58:39 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=131260


Gyuyoung Kim <gyuyoung.kim at samsung.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #228663|review?                     |review-
               Flag|                            |




--- Comment #2 from Gyuyoung Kim <gyuyoung.kim at samsung.com>  2014-04-05 03:58:59 PST ---
(From update of attachment 228663)
View in context: https://bugs.webkit.org/attachment.cgi?id=228663&action=review

> Source/WebKit2/ChangeLog:3
> +        [EFL][WK2] Fix unused parameter compile warning.

This patch is not only for [EFL]. Please remove [EFL] prefix.

> Source/WebKit2/UIProcess/API/APIDownloadClient.h:51
> +    virtual void didReceiveData(WebKit::WebContext*, WebKit::DownloadProxy*, uint64_t) { }

I prefer to use UNUSED_PARAM when parameter name is critical for clarity. In this case, length is that case.

UNUSED_PARAM(length); ?

Besides there was a discussion how to handle unused parameter in below thread.
https://lists.webkit.org/pipermail/webkit-dev/2012-October/022369.html

> Source/WebKit2/UIProcess/API/APIDownloadClient.h:52
> +    virtual bool shouldDecodeSourceDataOfMIMEType(WebKit::WebContext*, WebKit::DownloadProxy*, const WTF::String&) { return true; }

ditto.

> Source/WebKit2/UIProcess/API/APIDownloadClient.h:53
> +    virtual WTF::String decideDestinationWithSuggestedFilename(WebKit::WebContext*, WebKit::DownloadProxy*, const WTF::String&, bool&) { return { }; }

ditto.

> Source/WebKit2/UIProcess/API/APIDownloadClient.h:54
> +    virtual void didCreateDestination(WebKit::WebContext*, WebKit::DownloadProxy*, const WTF::String&) { }

ditto.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list