[Webkit-unassigned] [Bug 131237] Use preallocated stack reference to store adjacentBacktrackingStart

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Apr 5 00:46:18 PDT 2014


https://bugs.webkit.org/show_bug.cgi?id=131237


Yusuke Suzuki <utatane.tea at gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #228614|1                           |0
        is obsolete|                            |




--- Comment #4 from Yusuke Suzuki <utatane.tea at gmail.com>  2014-04-05 00:46:38 PST ---
(From update of attachment 228614)
View in context: https://bugs.webkit.org/attachment.cgi?id=228614&action=review

Thank you for your review!
I've fixed and attached revised patch.

>> Source/WebCore/cssjit/SelectorCompiler.cpp:210
>> +    bool m_needsAdjacentBacktrackingStart : 1;
> 
> You should not use a bit field here.
> 
> I would put the field just after m_selectorFragments since it is related to a global state of code generation.

Thank you! You're right.
I've removed a bit field. And moved m_needsAdjacentBacktrackingStart to just after m_selectorFragments.

>> Source/WebCore/cssjit/StackAllocator.h:63
>> +    StackReference push()
> 
> The name push() is a bit misleading. I think allocate() or allocateUninitialized() would be better.

Right. I've renamed it to allocateUninitialized.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list