[Webkit-unassigned] [Bug 122081] FTL: refactor compileAdd and compileArithSub into one function.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Sep 29 19:03:08 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=122081





--- Comment #2 from Geoffrey Garen <ggaren at apple.com>  2013-09-29 19:02:06 PST ---
(From update of attachment 212941)
View in context: https://bugs.webkit.org/attachment.cgi?id=212941&action=review

> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:285
>          case ValueAdd:
> -            compileAdd();
> +            compileAddSub(false /* this is an add */);
>              break;
>          case ArithSub:
> -            compileArithSub();
> +            compileAddSub(true /* this is a sub */);

WebKit style for booleans that are "true" or "false" constants at the call site is to use named enum values. Something like:

enum AddOrSub { Add, Sub };
compileAddOrSub(Add);
compileAddOrSub(Sub);

> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:696
> +            LValue C1 =lowDouble(m_node->child1());
> +            LValue C2 =lowDouble(m_node->child2());

Need spaces after the "="s.

> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:707
> -    
> +

Please revert this accidental whitespace change.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list