[Webkit-unassigned] [Bug 121784] Rename RenderObject::first/lastChild to RenderObject::first/lastChildSlow
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Sep 23 11:05:05 PDT 2013
https://bugs.webkit.org/show_bug.cgi?id=121784
--- Comment #3 from Andreas Kling <akling at apple.com> 2013-09-23 11:04:08 PST ---
(From update of attachment 212366)
View in context: https://bugs.webkit.org/attachment.cgi?id=212366&action=review
I guess we can and should tighten all these things, but here's some whining anyway:
> Source/WebCore/accessibility/AccessibilityRenderObject.cpp:328
> - return renderer->firstChild() && renderer->firstChild()->isInlineElementContinuation();
> + return renderer->firstChildSlow() && renderer->firstChildSlow()->isInlineElementContinuation();
Should we cache it in a local here to avoid double virtual dispatch?
> Source/WebCore/accessibility/AccessibilityRenderObject.cpp:370
> - return renderer->lastChild() && isInlineWithContinuation(renderer->lastChild());
> + return renderer->lastChildSlow() && isInlineWithContinuation(renderer->lastChildSlow());
And here.
> Source/WebCore/accessibility/AccessibilityRenderObject.cpp:464
> - if (firstChild == parent->firstChild())
> + if (firstChild == parent->firstChildSlow())
> break;
> - firstChild = parent->firstChild();
> + firstChild = parent->firstChildSlow();
Also here.
> Source/WebCore/dom/ContainerNode.cpp:898
> - if (o->firstChild())
> - o = o->firstChild();
> + if (o->firstChildSlow())
> + o = o->firstChildSlow();
etc.
> Source/WebCore/dom/ContainerNode.cpp:958
> - if (o->lastChild())
> - o = o->lastChild();
> + if (o->lastChildSlow())
> + o = o->lastChildSlow();
etc.
> Source/WebCore/rendering/RenderBlock.cpp:1081
> - if (prev && prev->firstChild() && prev->firstChild()->isInline() && prev->firstChild()->isRunIn())
> + if (prev && prev->firstChildSlow() && prev->firstChildSlow()->isInline() && prev->firstChildSlow()->isRunIn())
Oh here.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list