[Webkit-unassigned] [Bug 121221] RenderBR should not be RenderText
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Sep 17 10:20:53 PDT 2013
https://bugs.webkit.org/show_bug.cgi?id=121221
--- Comment #38 from Dave Hyatt <hyatt at apple.com> 2013-09-17 10:20:00 PST ---
(From update of attachment 211899)
View in context: https://bugs.webkit.org/attachment.cgi?id=211899&action=review
One change I'd like to see: Go ahead and add a new method, isTextOrBR() and use it. You have tons of call sites that have turned into isText() || isBR() and you might as well make a helper method that just handles that.
> Source/WebCore/ChangeLog:8
> + Stop inhering RenderBR from RenderText and make it be a RenderBoxModelObject instead. RenderBR was one
Typo. "inheriting"
> Source/WebCore/ChangeLog:12
> + didn't care about its text content at all. The new RenderText is also significatly more lightweight
Typo. "significantly"
> Source/WebCore/dom/Range.cpp:1649
> + if (r->isBR()) {
Get rid of braces here.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list