[Webkit-unassigned] [Bug 120397] Replace node() calls with generatingNode() for RenderRegion code

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 4 08:01:18 PDT 2013


--- Comment #4 from Darin Adler <darin at apple.com>  2013-09-04 08:00:36 PST ---
(From update of attachment 210433)
View in context: https://bugs.webkit.org/attachment.cgi?id=210433&action=review

> Source/WebCore/rendering/RenderRegion.h:147
> +    Element* generatingNodeForRegion() const;

This should be inlined; we don’t want function call overhead for what should be a free typecast. This should be called generatingElement, not generatedNodeForRegion.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list