[Webkit-unassigned] [Bug 123185] Refactor option parsing in WebKitTestRunner

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 22 16:46:36 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=123185





--- Comment #2 from WebKit Commit Bot <commit-queue at webkit.org>  2013-10-22 16:45:22 PST ---
Attachment 214902 did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Tools/ChangeLog', u'Tools/WebKitTestRunner/CMakeLists.txt', u'Tools/WebKitTestRunner/GNUmakefile.am', u'Tools/WebKitTestRunner/Options.cpp', u'Tools/WebKitTestRunner/Options.h', u'Tools/WebKitTestRunner/TestController.cpp', u'Tools/WebKitTestRunner/WebKitTestRunner.xcodeproj/project.pbxproj']" exit_code: 1
Tools/WebKitTestRunner/Options.h:30:  Alphabetical sorting problem.  [build/include_order] [4]
Tools/WebKitTestRunner/Options.h:32:  Alphabetical sorting problem.  [build/include_order] [4]
Tools/WebKitTestRunner/Options.h:34:  Streams are highly discouraged.  [readability/streams] [3]
Tools/WebKitTestRunner/Options.h:50:  c_defaultLongTimeout is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Tools/WebKitTestRunner/Options.h:51:  c_defaultShortTimeout is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Tools/WebKitTestRunner/Options.h:66:  The parameter name "o" adds no information, so it should be removed.  [readability/parameter_name] [5]
Tools/WebKitTestRunner/Options.h:68:  Missing spaces around =  [whitespace/operators] [4]
Tools/WebKitTestRunner/Options.cpp:27:  Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]
Tools/WebKitTestRunner/Options.cpp:29:  Streams are highly discouraged.  [readability/streams] [3]
Tools/WebKitTestRunner/Options.cpp:28:  Alphabetical sorting problem.  [build/include_order] [4]
Tools/WebKitTestRunner/Options.cpp:43:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:46:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:46:  handle_option_timeout is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Tools/WebKitTestRunner/Options.cpp:53:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:53:  handle_option_no_timeout is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Tools/WebKitTestRunner/Options.cpp:58:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:58:  handle_option_no_timeout_at_all is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Tools/WebKitTestRunner/Options.cpp:64:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:64:  handle_option_verbose is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Tools/WebKitTestRunner/Options.cpp:69:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:69:  handle_option_gc_between_tests is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Tools/WebKitTestRunner/Options.cpp:74:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:74:  handle_option_pixel_tests is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Tools/WebKitTestRunner/Options.cpp:79:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:79:  handle_option_print_supported_features is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Tools/WebKitTestRunner/Options.cpp:84:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:84:  handle_option_unmatched is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Tools/WebKitTestRunner/Options.cpp:87:  One line control clauses should not use braces.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:92:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:108:  Missing space inside { }.  [whitespace/braces] [5]
Tools/WebKitTestRunner/Options.cpp:110:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:114:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:116:  Missing spaces around =  [whitespace/operators] [4]
Tools/WebKitTestRunner/Options.cpp:116:  Missing spaces around <  [whitespace/operators] [3]
Tools/WebKitTestRunner/Options.cpp:116:  Missing space before ( in for(  [whitespace/parens] [5]
Tools/WebKitTestRunner/Options.cpp:116:  arg_counter is incorrectly named. Don't use underscores in your identifier names.  [readability/naming/underscores] [4]
Tools/WebKitTestRunner/Options.cpp:117:  Should have a space between // and comment  [whitespace/comments] [4]
Tools/WebKitTestRunner/Options.cpp:118:  Should have a space between // and comment  [whitespace/comments] [4]
Tools/WebKitTestRunner/Options.cpp:121:  Should have a space between // and comment  [whitespace/comments] [4]
Tools/WebKitTestRunner/Options.cpp:122:  Missing space before ( in for(  [whitespace/parens] [5]
Tools/WebKitTestRunner/Options.cpp:124:  Missing space before ( in if(  [whitespace/parens] [5]
Tools/WebKitTestRunner/Options.cpp:125:  Missing space before ( in if(  [whitespace/parens] [5]
Tools/WebKitTestRunner/Options.cpp:127:  Missing space before ( in if(  [whitespace/parens] [5]
Tools/WebKitTestRunner/Options.cpp:129:  Missing space before ( in if(  [whitespace/parens] [5]
Tools/WebKitTestRunner/Options.cpp:131:  One line control clauses should not use braces.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:133:  One line control clauses should not use braces.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:135:  Use 0 instead of NULL.  [readability/null] [5]
Tools/WebKitTestRunner/Options.cpp:136:  One line control clauses should not use braces.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:144:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:146:  Should have a space between // and comment  [whitespace/comments] [4]
Tools/WebKitTestRunner/Options.cpp:147:  Should have a space between // and comment  [whitespace/comments] [4]
Tools/WebKitTestRunner/Options.cpp:148:  Missing space before ( in for(  [whitespace/parens] [5]
Tools/WebKitTestRunner/Options.cpp:149:  Missing space before ( in if(  [whitespace/parens] [5]
Tools/WebKitTestRunner/Options.cpp:151:  One line control clauses should not use braces.  [whitespace/braces] [4]
Tools/WebKitTestRunner/Options.cpp:158:  Place brace on its own line for function definitions.  [whitespace/braces] [4]
Tools/WebKitTestRunner/TestController.cpp:33:  Alphabetical sorting problem.  [build/include_order] [4]
Total errors found: 56 in 7 files


If any of these errors are false positives, please file a bug against check-webkit-style.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list