[Webkit-unassigned] [Bug 121626] Spatial Navigation : User should be able to navigate html elemets having element.style.cursor="pointer"

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 4 06:01:46 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=121626


Antonio Gomes <tonikitoo at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #213246|review?, commit-queue?      |review-
               Flag|                            |




--- Comment #4 from Antonio Gomes <tonikitoo at webkit.org>  2013-10-04 06:00:39 PST ---
(From update of attachment 213246)
View in context: https://bugs.webkit.org/attachment.cgi?id=213246&action=review

r-. See comments.


Also, a question: this property (cursor: point) seems inheritable. What happens if one does <body style="cursor:point"> ?

> Source/WebCore/dom/Element.cpp:251
> +bool Element::isSpatialNavigationFocusable() const
> +{
> +    if (!document().frame() && !document().frame()->settings().spatialNavigationEnabled())
> +        return false;
> +
> +    if (!inDocument())
> +        return false;
> +
> +    if (!renderer() || renderer()->style()->visibility() != VISIBLE)
> +        return false;
> +
> +    return (renderer()->style()->cursor() == CURSOR_POINTER);
> +}
> +

this does not belong to Element. See more below.

> Source/WebCore/page/FocusController.cpp:768
> +        if (!element->isSpatialNavigationFocusable() && !element->isKeyboardFocusable(event) && !element->isFrameOwnerElement() && !canScrollInDirection(element, direction))

isSpatialNavigationFocusable belong, I believe to SpatialNavigation.h, and should likely be a static method, taking an Element*

Additionally, it should be named with cursor:point case in mind. isSpatialNavigationFocusable is too generic in this case. Maybe hasCursorPointStyle?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list