[Webkit-unassigned] [Bug 122205] FTL: Refactor compileArithDiv and compileArithMod into one function.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 2 09:15:37 PDT 2013


--- Comment #2 from Darin Adler <darin at apple.com>  2013-10-02 09:14:33 PST ---
(From update of attachment 213153)
View in context: https://bugs.webkit.org/attachment.cgi?id=213153&action=review

> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:657
> -    enum AddOrSubKind {Add, Sub};
> -    void compileAddSub(AddOrSubKind opKind)
> +    enum ArithKind {Add, Sub, Div, Mod};

Doesn’t seem helpful to share a single enum for these four kinds of arithmetic. Why not a second enum?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list