[Webkit-unassigned] [Bug 122928] New: Remove unnecessary check for RenderLayer and rename ensureLayer to createLayer in RenderLayerModelObject.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 16 16:59:56 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=122928

           Summary: Remove unnecessary check for RenderLayer and rename
                    ensureLayer to createLayer in RenderLayerModelObject.
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Keywords: BlinkMergeCandidate
          Severity: Normal
          Priority: P2
         Component: Layout and Rendering
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: vivekg at webkit.org
                CC: darin at apple.com


RenderLayerModelObject::styleDidChange() invokes the ensureLayer() method only in case of !layer().
Again checking for layer existence would be deemed redundant in ensureLayer. Replacing it with an
ASSERT(!m_layer).

Blink Review URL: https://codereview.chromium.org/27246003/

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list