[Webkit-unassigned] [Bug 122104] [ATK] Expose state of aria-invalid as ATK_STATE_INVALID_ENTRY

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 4 02:44:17 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=122104


Mario Sanchez Prada <mario at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #213251|0                           |1
        is obsolete|                            |
 Attachment #213251|review?                     |
               Flag|                            |
 Attachment #213346|                            |review?
               Flag|                            |




--- Comment #5 from Mario Sanchez Prada <mario at webkit.org>  2013-10-04 02:43:10 PST ---
Created an attachment (id=213346)
 --> (https://bugs.webkit.org/attachment.cgi?id=213346&action=review)
Patch proposal

(In reply to comment #4)
> (From update of attachment 213251 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=213251&action=review
> 
> > Source/WebCore/accessibility/atk/WebKitAccessibleWrapperAtk.cpp:729
> > +    if (!invalidStatus.isEmpty() && invalidStatus != "false")
> 
> invalidStatus should never be empty based on previous patch you submitted

Argh... true. Changed it

> > Tools/DumpRenderTree/atk/AccessibilityUIElementAtk.cpp:1045
> > +        // If no text attribute was found, just return what the state says.
> 
> this comment is not necessary. you're just explaining what the code does rather than why it does it
> 

Removed

> > Tools/DumpRenderTree/atk/AccessibilityUIElementAtk.cpp:1051
> > +        if (isInvalidState != (attributeValue != "false"))
> 
> this is a little confusing. maybe split this into to two if/if statements for clarity?

I replaced it with this:

    bool isAriaInvalid = attributeValue != "false";
    if (isInvalidState != isAriaInvalid) {
        return JSStringCreateWithCharacters(0, 0);
    }

I guess that way is more clear now.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list