[Webkit-unassigned] [Bug 122205] FTL: Refactor compileArithDiv and compileArithMod into one function.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 2 10:25:35 PDT 2013


--- Comment #7 from Filip Pizlo <fpizlo at apple.com>  2013-10-02 10:24:31 PST ---
(From update of attachment 213172)
View in context: https://bugs.webkit.org/attachment.cgi?id=213172&action=review

> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:294
> -            compileArithDiv();
> +            compileArithDivMod(Div);
>              break;
>          case ArithMod:
> -            compileArithMod();
> +            compileArithDivMod(Mod);

General comment: is there a reason why we even have an enum that we pass to these?

For example, compileArithMinOrMax() doesn't take any arguments; it figures out what it should do by looking at m_node->op() - either it's ArithMin or ArithMax.  Hence no need for an argument or a separate enum.

What do you think about that for DivOrMod() and AddOrSub()?

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list