[Webkit-unassigned] [Bug 122205] FTL: Refactor compileArithDiv and compileArithMod into one function.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 2 09:37:17 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=122205


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #213169|review?, commit-queue?      |review+, commit-queue-
               Flag|                            |




--- Comment #5 from Darin Adler <darin at apple.com>  2013-10-02 09:36:13 PST ---
(From update of attachment 213169)
View in context: https://bugs.webkit.org/attachment.cgi?id=213169&action=review

> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:783
> +    enum DivOrModKind {Div, Mod};

Formatting error. We use spaces inside the braces.

> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:787
> +        bool isDiv = opKind == Div;

Seems like we could say "opKind == Div" at the two sites where this is used. The boolean doesn’t add significant clarity.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list