[Webkit-unassigned] [Bug 122681] [GTK] Search functionality in MiniBrowser provides feedback on search fail
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Nov 25 04:14:16 PST 2013
https://bugs.webkit.org/show_bug.cgi?id=122681
Mario Sanchez Prada <mario at webkit.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #214034|review? |review-
Flag| |
--- Comment #2 from Mario Sanchez Prada <mario at webkit.org> 2013-11-25 04:12:45 PST ---
(From update of attachment 214034)
View in context: https://bugs.webkit.org/attachment.cgi?id=214034&action=review
I think it's a good idea, I would just do a small change in the code. See it below...
> Tools/MiniBrowser/gtk/BrowserSearchBar.c:46
> +static void setEntryBackgroundColor(BrowserSearchBar *searchBar, gboolean failedSearch)
This function is named setEntryBackgroundColor(), but it does not set any color at all, just specifies whether the search failed (so the color is set accordingly).
So, I think you either rename it to something that makes more sense according to the bool parameter (e.g. setFailedStyleForEntry()), so the bool TRUE means "failed" and FALSE means "ok/default", or you go further to even avoid the bool parameter by declaring a new enum with ENTRY_STYLE_DEFAULT/OK/FAIL values (for instance) to be passed to the function, which maybe I would rename then to setStyleForEntry().
For MiniBrowser, I do not have any special preference over those. Any option would be ok to me :)
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list