[Webkit-unassigned] [Bug 124666] Simple line layout should support floats

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 20 12:44:47 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=124666


Dave Hyatt <hyatt at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #217459|review?                     |review+
               Flag|                            |




--- Comment #6 from Dave Hyatt <hyatt at apple.com>  2013-11-20 12:43:21 PST ---
(From update of attachment 217459)
View in context: https://bugs.webkit.org/attachment.cgi?id=217459&action=review

r=me. I'm a bit concerned about all the physical naming though. This layout should obviously work with vertical text too, so the naming needs to be a bit less writing-mode-biased.

> Source/WebCore/rendering/SimpleLineLayoutResolver.h:111
> +    const LayoutUnit m_topBorderAndPadding;

Rename this to m_beforeBorderAndPadding.

> Source/WebCore/rendering/SimpleLineLayoutResolver.h:179
>      float baselineY = resolver.m_lineHeight * m_iterator.lineIndex() + resolver.m_baseline;

Would be nice if this "baselineY" didn't contain "Y" since it's horizontal for vertical text... Maybe just baselinePosition or baselineOffset?

> Source/WebCore/rendering/SimpleLineLayoutResolver.h:256
> +    , m_topBorderAndPadding(flow.borderTop() + flow.paddingTop())

Shouldn't this be 'before" rather than "top"?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list