[Webkit-unassigned] [Bug 123885] AX: [ATK] <span> elements exposed through ATK when not needed

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 6 11:04:05 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=123885





--- Comment #5 from chris fleizach <cfleizach at apple.com>  2013-11-06 11:02:51 PST ---
(In reply to comment #4)
> (From update of attachment 216177 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=216177&action=review
> 
> >> Source/WebCore/accessibility/AccessibilityNodeObject.cpp:1925
> >> +
> > 
> > can all these checks move into AccessibilityObject?
> 
> Hmm... yes and no: we can move the MathML part but not the ariaAccessibilityDescription() call since that's a non-virtual method from AccessibilityNodeObject.
> 
> >> Source/WebCore/accessibility/AccessibilityObject.h:608
> >> +    virtual bool hasAccessibleName() const;
> > 
> > I think this should be called something like hasAccessibleAttributes() or hasRequiredInclusionAttributes() or hasAttributedRequiredForInclusion()
> > 
> > something to denote that this method should be used to determine whether to include it in the tree
> 
> Believe it or not, I struggled to find a name for this and in the end this is the least bad I found.
> 
> hasAttributedRequiredForInclusion() sounds good to me, though

should be: hasAttributesRequiredForInclusion()

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list