[Webkit-unassigned] [Bug 121079] structure of frame tree is not correct in WINCE port.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Nov 3 20:22:22 PST 2013


https://bugs.webkit.org/show_bug.cgi?id=121079





--- Comment #15 from Zhuang Zhigang <zhuangzg at cn.fujitsu.com>  2013-11-03 20:21:08 PST ---
(In reply to comment #13)
> (From update of attachment 215725 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=215725&action=review
> 
> > Source/WebKit/wince/WebView.cpp:159
> >  PassRefPtr<Frame> WebView::createFrame(const URL& url, const String& name, HTMLFrameOwnerElement* ownerElement, const String& referrer,
> > -                                       bool /*allowsScrolling*/, int /*marginWidth*/, int /*marginHeight*/)
> > +    bool /*allowsScrolling*/, int /*marginWidth*/, int /*marginHeight*/, Frame* frame)
> 
> Argument should be named parentFrame.
> 
Yes, I see.
Argument name was changed.
Then removed assignment for "coreFrame" and changed remaining of "coreFrame" to "parentFrame".

> > Source/WebKit/wince/WebView.h:72
> > +    PassRefPtr<WebCore::Frame> createFrame(const WebCore::URL&, const WTF::String&, WebCore::HTMLFrameOwnerElement*, const WTF::String&, bool, int, int, WebCore::Frame*);
> 
> Should give the arguments names here, except the ones that are obvious from the type along. The meanings of the strings, bool, ints, and frame are not obvious.
OK, I added the arguments names for these strings, bool, ints, and frame.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list