[Webkit-unassigned] [Bug 121079] structure of frame tree is not correct in WINCE port.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 1 11:51:08 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=121079


Darin Adler <darin at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #215725|review?                     |review+
               Flag|                            |




--- Comment #13 from Darin Adler <darin at apple.com>  2013-11-01 11:49:54 PST ---
(From update of attachment 215725)
View in context: https://bugs.webkit.org/attachment.cgi?id=215725&action=review

> Source/WebKit/wince/WebView.cpp:159
>  PassRefPtr<Frame> WebView::createFrame(const URL& url, const String& name, HTMLFrameOwnerElement* ownerElement, const String& referrer,
> -                                       bool /*allowsScrolling*/, int /*marginWidth*/, int /*marginHeight*/)
> +    bool /*allowsScrolling*/, int /*marginWidth*/, int /*marginHeight*/, Frame* frame)

Argument should be named parentFrame.

> Source/WebKit/wince/WebView.h:72
> +    PassRefPtr<WebCore::Frame> createFrame(const WebCore::URL&, const WTF::String&, WebCore::HTMLFrameOwnerElement*, const WTF::String&, bool, int, int, WebCore::Frame*);

Should give the arguments names here, except the ones that are obvious from the type along. The meanings of the strings, bool, ints, and frame are not obvious.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list