[Webkit-unassigned] [Bug 70117] Expose HTMLCanvasElement supportsContext

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 31 13:35:07 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=70117





--- Comment #18 from Ruth Fong <ruthiecftg at gmail.com>  2013-05-31 13:33:39 PST ---
(From update of attachment 203462)
View in context: https://bugs.webkit.org/attachment.cgi?id=203462&action=review

>> Source/WebCore/html/HTMLCanvasElement.cpp:212
>> +    if (attrs) { }
> 
> Please file a bug and include the link. Don't include the empty statements.

I'm not sure if this is the proper way to handle the fact that I'm not using the attributes but that the W3 definition of supportsContext supports additional arguments. I got this error when submitting the patch: 
Source/WebCore/html/HTMLCanvasElement.h:95:  The parameter name "attributes" adds no information, so it should be removed.  [readability/parameter_name] [5]

> Source/WebCore/html/HTMLCanvasElement.cpp:216
> +    if (type == "2d") {

This method is modeled after how HTMLCanvasElement::getContext was written, but I'm not sure that's necessary.

>> LayoutTests/fast/canvas/webgl/canvas-supports-context.html:7
>> +<script src="resources/webgl-test.js"></script>
> 
> Nor this.

Do I need this for finishTest() (which calls notifyDone)?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list