[Webkit-unassigned] [Bug 112615] [css3-text] Implement support for vertical writing mode in -webkit-text-underline-position

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon May 27 06:15:31 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=112615





--- Comment #11 from Lamarque V. Souza <Lamarque.Souza at basyskom.com>  2013-05-27 06:14:01 PST ---
(In reply to comment #8)
> Thank you for your advice.

You are welcome :-)

> (In reply to comment #2)
> Yes, these are not valid value.
> We should check invalid case.
> These test cases found my bugs, so I think adding this to trunk is valuable.

I agree, just that you added them to the wrong file. You should have used getComputedStyle-text-underline-position.html for checking the parser of this patch. The other unit tests are for the rendering part. Keep in mind that getComputedStyle-text-underline-position.html is text only test and the others are pixel tests. You do not need pixel tests to test the parser.

(In reply to comment #9)
> Added test cases to getComputedStyle-text-underline-position.html.
> I found that I should implement CSSValueList behavior, so I implemented it.

Good.

> >  Anything that is not either "auto", "alphabetic", "under", "under left" or "under right" is invalid.
> 
> This is not correct.
> "left under" and "right under" are also valid value.
> There is the definition of || in CSS2.1[1]
> > A double bar (||) separates two or more options: one or more of them must occur, in any order.
> 
> This says "in any order", so we can write "left under" or "right under".
> 
> [1]: http://www.w3.org/TR/CSS21/about.html#property-defs

Ok about that then.(In reply to comment #10)
> (In reply to comment #7)
> > Attachment 202967 [details] [details] did not pass style-queue:
> > 
> > Source/WebCore/rendering/InlineTextBox.cpp:984:  An else if statement should be written as an if statement when the prior "if" concludes with a return, break, continue or goto statement.  [readability/control_flow] [4]
> > Total errors found: 1 in 22 files
> > 
> > 
> > If any of these errors are false positives, please file a bug against check-webkit-style.
> 
> The outer "if" dose not conclude with a return.
> This may be bug of style checker.

What the error message want to say is that you should do:

if (...)
    return <something>;
if (...)
    return <something>;

instead of

if (...)
    return <something>;
else if (...)
    return <something>;

You just need to remove the "else"'s in your source code. They are not necessary if there is a return inside the if statement.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list