[Webkit-unassigned] [Bug 115564] Web Inspector: Implement WK2 version of WebInspectorFrontendClient::save

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 10 13:06:18 PDT 2013


--- Comment #28 from Timothy Hatcher <timothy at apple.com>  2013-05-10 13:04:40 PST ---
(From update of attachment 201268)
View in context: https://bugs.webkit.org/attachment.cgi?id=201268&action=review

>> Source/WebKit/mac/WebCoreSupport/WebInspectorClient.mm:315
>>      };
> What is the point of this block exactly?

It reduces some code duplication. It is called twice in this function.

>> Source/WebKit2/UIProcess/WebInspectorProxy.h:169
>> +    void platformAppend(const String& filename, const String& content);
> I find it intrinsically weird to pass any file content as String. I am not aware of any API that works like that.

We use String because the content comes from JavaScript (via the JSON Inspector protocol), where string is the only type we have to work with for this sort of thing.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list