[Webkit-unassigned] [Bug 115804] Avoid unnecessary data copies when loading subresources with DoNotBufferData option

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 8 11:12:41 PDT 2013


--- Comment #9 from Brady Eidson <beidson at apple.com>  2013-05-08 11:11:05 PST ---
(In reply to comment #7)
> (In reply to comment #5)

> > > Source/WebCore/loader/cache/CachedResource.h:105
> > > +    virtual void data(const char* /*data*/, int /*length*/) { }

> > Assuming all tests continue passing without that ASSERT firing, I'd like us to take it a step further and name this method something different instead of just overloading ::data().  "unbufferedData()" is my first instinct, though I'm aware that's not perfect.
> Yes, I also thought about the names, my initial idea was to rename the current one to buffer or resourceBuffer and this new as data, but I wanted to keep the patch as simple as possible and buffer doesn't sound like a great name anyway. For now, I left both as data so that they can be renamed when refactoring. 

Please name it something else now.

"data()" is already such a truly terrible name, and overloading truly terrible names is even more truly terrible.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list