[Webkit-unassigned] [Bug 115804] Avoid unnecessary data copies when loading subresources with DoNotBufferData option
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed May 8 11:05:33 PDT 2013
https://bugs.webkit.org/show_bug.cgi?id=115804
--- Comment #8 from Ryosuke Niwa <rniwa at webkit.org> 2013-05-08 11:03:57 PST ---
(From update of attachment 201079)
View in context: https://bugs.webkit.org/attachment.cgi?id=201079&action=review
>>> Source/WebCore/loader/cache/CachedResource.h:105
>>> + virtual void data(const char* /*data*/, int /*length*/) { }
>>
>> Lets give this an implementation in CachedResource.cpp and have it ASSERT(m_options.dataBufferingPolicy == DoNotBufferData)
>>
>> Assuming all tests continue passing without that ASSERT firing, I'd like us to take it a step further and name this method something different instead of just overloading ::data(). "unbufferedData()" is my first instinct, though I'm aware that's not perfect.
>
> Yes, I also thought about the names, my initial idea was to rename the current one to buffer or resourceBuffer and this new as data, but I wanted to keep the patch as simple as possible and buffer doesn't sound like a great name anyway. For now, I left both as data so that they can be renamed when refactoring.
>
> Do apple EWS bots run the tests with asserts enabled?
No. You have to run tests manually on a debug build yourself as clearly outlined in http://www.webkit.org/coding/contributing.html.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list