[Webkit-unassigned] [Bug 115722] [sh4] Take advantage of pre-decrement and post-increment opcodes for sh4 base JIT

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 7 08:55:52 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=115722





--- Comment #5 from Oliver Hunt <oliver at apple.com>  2013-05-07 08:54:16 PST ---
(From update of attachment 200892)
View in context: https://bugs.webkit.org/attachment.cgi?id=200892&action=review

I had some war moments while reading this, so i'll hold off on r+ pending replies

> Source/JavaScriptCore/assembler/MacroAssemblerSH4.h:1043
> -        m_assembler.loadConstant(address.offset, scr);
> +        m_assembler.loadConstant(address.offset + 8, scr);

wat?

> Source/JavaScriptCore/assembler/MacroAssemblerSH4.h:1057
> +        add32(TrustedImm32(address.offset + 8), scr);

again wat?

> Source/JavaScriptCore/assembler/MacroAssemblerSH4.h:1170
> -        m_assembler.ensureSpace(m_assembler.maxInstructionSize + 68, sizeof(uint32_t));
> +        m_assembler.ensureSpace(m_assembler.maxInstructionSize + 58, sizeof(uint32_t));

This magic constant scares me, what is it?

>>> Source/JavaScriptCore/assembler/SH4Assembler.h:120
>>> +    MOVW_READ_RMINC_OPCODE = 0x6005,
>> 
>> enum members should use InterCaps with an initial capital letter.  [readability/enum_casing] [4]
> 
> All other 100+ entries in this enum are in capital letters, so I think I'll leave it as it is.

I think we just need to modify the style bot to ignore these

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list