[Webkit-unassigned] [Bug 114809] [WK2][GTK] ExceededDatabaseQuota method support in WebKitUIClient
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Fri May 3 06:43:04 PDT 2013
https://bugs.webkit.org/show_bug.cgi?id=114809
--- Comment #22 from Martin Robinson <mrobinson at webkit.org> 2013-05-03 06:41:25 PST ---
(From update of attachment 200076)
View in context: https://bugs.webkit.org/attachment.cgi?id=200076&action=review
Looks good to me. Since this adds new API it needs review from two GTK+ reviewers and also a WebKit2 owner.
> Source/WebKit2/UIProcess/API/gtk/WebKitSettings.cpp:68
> + guint64 defaultWebDatabaseQuota;
You shoult use int64_t here, if possible.
> Source/WebKit2/UIProcess/API/gtk/WebKitSettings.cpp:1086
> + * The default quota for Web SQL Databases
You might want to talk briefly about what happens when the quota is reached.
> Source/WebKit2/UIProcess/API/gtk/WebKitSettings.cpp:1173
> +void webkit_settings_set_default_web_database_quota(WebKitSettings* settings, guint64 default_quota)
Here, but not in the doc or the header, you should rename default_quota to defaultQuota.
> Source/WebKit2/UIProcess/API/gtk/WebKitWebView.cpp:1568
> + guint64 quota = webkit_settings_get_default_web_database_quota(settings);
> +
> + return quota;
You could just do
return webkit_settings_get_default_web_database_quota(settings);
here.
> Tools/MiniBrowser/gtk/BrowserSettingsDialog.c:146
> + uIntProperty->maximum, 1, 1, 1);
It's okay to make this one line.
> Tools/MiniBrowser/gtk/BrowserSettingsDialog.c:151
> + adjustment = gtk_adjustment_new(uInt64Property->default_value, uInt64Property->minimum,
> + uInt64Property->maximum, 1, 1, 1);
Ditto.
> Tools/MiniBrowser/gtk/main.c:155
> - || gParamType == G_TYPE_FLOAT);
> + || gParamType == G_TYPE_UINT64 || gParamType == G_TYPE_FLOAT);
Ditto.
> Tools/MiniBrowser/gtk/main.c:253
> +
Looks like this snuck in by accident.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list